Failing to eject - Page 2
Like Tree4Likes
Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 21

Thread: Failing to eject

  1. #11
    XCR Guru navalbeaver's Avatar
    Join Date
    Jan 2010
    Location
    Redneck Riviera
    Posts
    1,780
    Quote Originally Posted by Thequickmick View Post
    Should the extractor have any play in it? I can move it back and forth fairly easy.
    Extractor, on the bolt? Just making sure.

    How much force to move? If it's not much(relatively), it may be a bad or worn out spring.

  2. #12
    XCR Guru Sean K.'s Avatar
    Join Date
    Nov 2008
    Location
    AZ
    Posts
    19,973
    Quote Originally Posted by Col Maddog View Post
    I may be fortunate but every issue I have had similar to yours was in fact a bad magazine. I own two XCR's and a bad 6.8 mag was the issue. A bad magazine also created similar problems in a Sig 551 which really pissed me off because they (mags) are quite expensive!
    Good point....might try different mags, however....bad mags usually exhibit themselves though problems with feeding, not ejecting.
    "Necessity is the plea for every infringement of human liberty. It is the argument of tyrants; the creed of slaves."-William Pitt the Younger

  3. #13
    XCR Guru mjorin's Avatar
    Join Date
    Aug 2010
    Posts
    3,162
    As stated by Sean, do you have the correct ejection port buffer? Maybe you answered that. I'm assuming you've run it on the highest gas setting?

  4. Remove Advertisements
    XCRForum.com
    Advertisements
     

  5. #14
    XCR Guru mjorin's Avatar
    Join Date
    Aug 2010
    Posts
    3,162
    What do you mean stuck in the port? Completely in the port? Stove pipe? Partially stuck in chamber? Just curious.

  6. #15
    Newbie Thequickmick's Avatar
    Join Date
    Mar 2017
    Posts
    9
    Jammed against the bolt and ejection port most of the time. I can wiggle the extractor on the bolt easily, I'm going to order a new extractor and spring and go from there. I've tried 4 different mags didn't help. Everything to me at least looks good.

  7. #16
    XCR Guru mjorin's Avatar
    Join Date
    Aug 2010
    Posts
    3,162
    Ejection port buffer? Gas setting? How does it do with manual extraction?

  8. #17
    XCR Guru navalbeaver's Avatar
    Join Date
    Jan 2010
    Location
    Redneck Riviera
    Posts
    1,780
    I've got common parts kits & spares available let me know if you're interestedI

  9. #18
    Newbie Thequickmick's Avatar
    Join Date
    Mar 2017
    Posts
    9
    Recieved my new extractor spring and extractor today, seems to get a lot tighter and with an empty cartridge not loose at all. Hopefully this will fix the problem.

  10. #19
    Newbie Thequickmick's Avatar
    Join Date
    Mar 2017
    Posts
    9
    Out to the range today, shot around 100 rounds had zero problems.
    Sean K. and Merlin like this.

  11. #20
    XCR Guru Sean K.'s Avatar
    Join Date
    Nov 2008
    Location
    AZ
    Posts
    19,973
    Glad to hear.....

    Enjoy!
    "Necessity is the plea for every infringement of human liberty. It is the argument of tyrants; the creed of slaves."-William Pitt the Younger

Page 2 of 3 FirstFirst 123 LastLast

Sponsors

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. 7.62X39 Failure to Eject
    By Quixtarblade in forum Problems
    Replies: 21
    Last Post: 05-11-2013, 03:02 PM
  2. Failure to eject
    By Rob in forum Problems
    Replies: 62
    Last Post: 07-29-2011, 01:33 AM
  3. Failing to Show up to the Future
    By Difranco in forum Politicking
    Replies: 0
    Last Post: 07-13-2011, 07:15 AM
  4. XCR is double feeding and failing to feed
    By xela in forum Problems
    Replies: 25
    Last Post: 01-30-2010, 10:32 AM
  5. Failure To Eject
    By PDBreske in forum Problems
    Replies: 64
    Last Post: 12-03-2009, 10:42 AM