Accuracy issues with my XCR in 5.56
Results 1 to 4 of 4

Thread: Accuracy issues with my XCR in 5.56

  1. #1
    Newbie waveslayer's Avatar
    Join Date
    Feb 2013
    Posts
    2

    Accuracy issues with my XCR in 5.56

    I recently bought the Nikon P-223 scope. I have it sighted in for 100 yards. My shots are all over the place. I have a large grouping, about a 3-4'' MOA @ 100yds. I am using Federal Ammo, .223 55Gr. What could be causing this. My RRA using the same ammo shoots a sub MOA at 100 yards. same barrel twist.


  2. #2
    Marksman Twisted Jester's Avatar
    Join Date
    Dec 2009
    Posts
    437

    Re: Accuracy issues with my XCR in 5.56

    Things to check (assuming your optic actually is known good)

    1) Make sure your optic is on solid.

    2) Check barrel torque

    3) Make sure you know how to shoot

    not necessarily in that order....
    It's all fun and games till you get off at Auschwitz.

  3. #3
    Expert wombat338's Avatar
    Join Date
    Dec 2011
    Posts
    1,291

    Re: Accuracy issues with my XCR in 5.56

    Quote Originally Posted by waveslayer View Post
    I recently bought the Nikon P-223 scope. I have it sighted in for 100 yards. My shots are all over the place. I have a large grouping, about a 3-4'' MOA @ 100yds. I am using Federal Ammo, .223 55Gr. What could be causing this. My RRA using the same ammo shoots a sub MOA at 100 yards. same barrel twist.
    Uh, accuracy issues with what XCR?

    Quote Originally Posted by waveslayer View Post
    RA is terrible at responding to calls or emails! I wanted to spend some money with them and they wouldn't even respond! frustrating. So I bought from someone else.
    “Americans have the right and advantage of being armed – unlike the citizens of other countries whose governments are afraid to trust the people with arms.” -- James Madison

  4. Remove Advertisements
    XCRForum.com
    Advertisements
     

  5. #4
    Expert crusoe's Avatar
    Join Date
    Sep 2011
    Posts
    1,184

    Re: Accuracy issues with my XCR in 5.56

    How do you compare the trigger on your XCR to that on your RRA? Perhaps this is part of your problem. Do you have the old or new trigger? Your RRA may have a better trigger and/or one you are more used to using.

    Look at your XCR manual and make sure all your fasteners are tight.

    Ditto on the scope mounts. If you put it on the XCR recently and then shot it, your scope mount fasteners may need to be snugged up again.

    Good luck and let us know if and how you solved the problem.

Sponsors

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Break-in issues (Accuracy & casing damage)
    By Hoag in forum Cleaning & Maintenance
    Replies: 20
    Last Post: 10-01-2020, 02:09 PM
  2. New AR issues
    By saberune in forum General Discussion
    Replies: 12
    Last Post: 02-09-2013, 12:08 PM
  3. Who has an -M? Any issues?
    By TomAiello in forum General Discussion
    Replies: 3
    Last Post: 11-25-2012, 03:57 PM
  4. Trigger Issues
    By Skorenzy in forum Problems
    Replies: 10
    Last Post: 08-31-2011, 04:06 PM
  5. Replies: 8
    Last Post: 12-06-2009, 06:56 AM

Search tags for this page

p-223 sighted at 100 yards

Click on a term to search for related topics.