Bolt stuck open three times today - Page 2
Like Tree15Likes
Page 2 of 5 FirstFirst 1234 ... LastLast
Results 11 to 20 of 49

Thread: Bolt stuck open three times today

  1. #11
    Newbie Canadian Eh's Avatar
    Join Date
    Feb 2013
    Posts
    15
    I'm quite new to firearms and definitely a novice with the XCR-L so feel free to correct me if I use the wrong term for something or an just not understanding basic functions of the mechanism. It ran the first 60 rounds through with not one issue (besides the trigger slap I mentioned). Then jammed/stuck the bolt back in the last 3 of four magazines. Again your input is greatly valued.

  2. #12
    Marksman 32875's Avatar
    Join Date
    Feb 2013
    Location
    Drumheller ab
    Posts
    693
    my bolt/carrier also has the gold rub marks but my bolt doesn't "stick" so I don't think that is your issue.........is your bolt moving in the carrier fine not catching or hanging up?

  3. #13
    Newbie Canadian Eh's Avatar
    Join Date
    Feb 2013
    Posts
    15
    The bolt seemed to be moving well. I do recall it being stuck back one time when I popped it open to unjam. The back of the bolt sticks out the back and gave it a push forward with a thumb to release the whole unit forward. I fit happens again I'll take careful note and maybe shoot a short video. Maybe it was just a but dry/dirty?

  4. Remove Advertisements
    XCRForum.com
    Advertisements
     

  5. #14
    XCR Guru Sean K.'s Avatar
    Join Date
    Nov 2008
    Location
    AZ
    Posts
    21,213
    The brass marks are normal. You *could* very carefully polish the bottom of the carrier....but don't change the geometry of anything and don't take it down at all....just polish it.
    "Necessity is the plea for every infringement of human liberty. It is the argument of tyrants; the creed of slaves."-William Pitt the Younger

  6. #15
    Marksman 32875's Avatar
    Join Date
    Feb 2013
    Location
    Drumheller ab
    Posts
    693
    agree with sean k pull bolt outta carrier run finger inside carrier and around bolt feeling for rough spots

  7. #16
    XCR Guru Bravo's Avatar
    Join Date
    Nov 2007
    Posts
    4,533
    Quote Originally Posted by Canadian Eh View Post
    Maybe it was just a but dry/dirty?
    That won't do it - these things run fine when they've not been lubed, cleaned, or anything but fired for several thousand rounds.

    Sean knows his stuff. Give it a go. But yes, some pictures - especially a video - would help a bunch.
    Do you really think we want laws to be observed? We want them broken. There's no way to rule innocent men. The only power any government has is the power to crack down on criminals. When there aren't enough criminals, one makes them. One declares so many things to be crimes that it becomes impossible for men to live without breaking laws. Who wants law-abiding citizens? Pass the kind of laws that can’t be observed, enforced, or objectively interpreted - and you create a nation of law-breakers.

  8. #17
    Newbie Canadian Eh's Avatar
    Join Date
    Feb 2013
    Posts
    15
    It'll be next weekend before I can get out again and see if it recurs. I'll take along a camera or phone to document what happens if it does it again. Thanks for all the great and constructive input.

  9. #18
    XCR Guru mjorin's Avatar
    Join Date
    Aug 2010
    Posts
    3,460
    Update?

  10. #19
    Newbie apexi's Avatar
    Join Date
    Mar 2013
    Posts
    3
    Had the same thing start happening to mine. It's been flawless for about 700rds but now I'm noticing on the last round of each mag, that it'll get snug, such that you got to give it a bit of a tug to pull back the bolt and release. Eventually after a few more mags the bolt will jam rock solid after the last round is fired,and no amount of muscling will make it budge. Anybody have any ideas on what's going on? Checked the ejector and it's on solid...furthermore the bolt slides effortlessly during racking so don't know what is causing it to get locked up like this.

  11. #20
    Newbie Canadian Eh's Avatar
    Join Date
    Feb 2013
    Posts
    15
    I have not got out to shoot it since. I pulled it apart, checked for any wear or damage and lubed it all up really well. Everything looks fine, ejector is solid, no marks on the buffer. Like you it cycled properly until the last round in the magazine them jammed solid with the bolt stuck back. It manually cycles fine when unjammed. I'm likely not even at 200 rds yet. I'll test it out this weekend if I can and post up the results. Please let me know if you find out anything on yours.

Page 2 of 5 FirstFirst 1234 ... LastLast

Sponsors

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Bolt Catch / Bolt Hold Open / BHO damage
    By jimbabwe in forum In The Field
    Replies: 13
    Last Post: 03-25-2012, 07:36 PM
  2. bolt stuck closed...updated !!
    By flht3 in forum Problems
    Replies: 68
    Last Post: 04-01-2010, 10:30 AM
  3. New vs. Old, Bolt Hold Open
    By aziator in forum General Discussion
    Replies: 12
    Last Post: 09-14-2009, 02:40 AM
  4. Replies: 25
    Last Post: 04-03-2009, 08:57 PM
  5. Replies: 0
    Last Post: 05-10-2008, 02:36 PM

Search tags for this page

xcr bolt carrier stuck

,

xcr bolt discoloration

,

xcr bolt wear

,

xcr-l bolt buffers

Click on a term to search for related topics.