SBR Issues and the Piston
Like Tree1Likes
  • 1 Post By Dredd
Results 1 to 7 of 7

Thread: SBR Issues and the Piston

  1. #1
    Expert Dredd's Avatar
    Join Date
    Oct 2008
    Posts
    985

    SBR Issues and the Piston

    So I finally got my SBR to the range. It was awesome... Just be careful with the gas setting. Setting four kinda beats you up when use a 11.5" barrel. I did have some 2 FTEs. I had 5 keyholes with the green tip ammo 1st target, then I switched to ZQI 62 grn had one keyhole. The last target is the Wolf Gold 55 grn.

    SBR Issues and the Piston-20160515_105152.jpgSBR Issues and the Piston-20160515_105229.jpgSBR Issues and the Piston-20160515_111720.jpgSBR Issues and the Piston-20160515_114305.jpg


    Then the rifle had a slight problem.... Nothing too serious just a busted piston....

    SBR Issues and the Piston-20160515_110630.jpg

    Fortunately I had my other XCR and used the piston from it to continue shooting.

    I started out using greet tip ammo, then I switched to ZQI 62 grn, about 90 rnds into the ZQI is when the piston failed. I will be talking to RA tomorrow and see if I can get a new one. I do have a spare piston in my spare kit.

    Any thoughts from the peanut gallery....

    Thank you
    'Courage is not the absences of fear, its the taking of action in the presences of fear."

  2. #2
    XCR Guru navalbeaver's Avatar
    Join Date
    Jan 2010
    Location
    Redneck Riviera
    Posts
    2,209
    Twist on the barrel?

    Any marks on the piston head?

    How low did you go on the gas?

    Any issues with that ammo in other platforms?

    I had a 9" barrel that would shoot 55gr reloads with some terrible groups (same ammo is great in my other rifles). Same barrel shot Serbian ss109 much much better. I've never had a problem with an OP rod. 2 pistons on the same day makes me think there's an issue with the rifle.

  3. #3
    Expert Dredd's Avatar
    Join Date
    Oct 2008
    Posts
    985
    The 11.5" brl is 1/7. The green tip and the Wolf gold has worked well in my both of my XCR-Ls, I use the Wolf in my Deawoo K1A1 (1/12 brl). The green tips key hole. This was the first time I used the ZQI. I will test it with my AR and my 16" XCR.

    The gas setting for the green tips was as 4 (10 rds). That beat my shoulder, so I moved it to 2 (10 rds). It was still a bit harsh, I then dropped it to 1. I kept is 1 for the rest of the session. No marks on the piston head. Also just to clarify I only loss 1 piston.

    To add: This thing really had to be harsh, the Battlecomp 1.0 loosen, Troy Ind. Low profile sites had to be tighten, when I got home and was inspecting all of the parts, the barrel nut needed to be tighten too.
    Last edited by Dredd; 05-15-2016 at 09:36 PM.
    'Courage is not the absences of fear, its the taking of action in the presences of fear."

  4. Remove Advertisements
    XCRForum.com
    Advertisements
     

  5. #4
    XCR Guru Sean K.'s Avatar
    Join Date
    Nov 2008
    Location
    AZ
    Posts
    21,225
    Looks like a one piece, non-welded op rod, correct?
    "Necessity is the plea for every infringement of human liberty. It is the argument of tyrants; the creed of slaves."-William Pitt the Younger

  6. #5
    XCR Guru navalbeaver's Avatar
    Join Date
    Jan 2010
    Location
    Redneck Riviera
    Posts
    2,209
    If it's still strong on 1, I'd try "S" just because. Port may be out of spec. I usually run my SBRs on 2. Some can go to 1 but I'll get failure to lock back or some short stroking.

    Misread about the rod.

    Based on the longer piston head I'd guess that's one of the newer one piece rods. I'd give RA a call. I'd assume that would be replaced by them.

    No clue on the keyholing. Were you shooting for groups at all?

    edit: not directly related but I had to send some gas blocks back to RA last week because the were drilled improperly. I can't verify that but they told me before I received them not to install them and that they'd swap them out.

  7. #6
    Expert Dredd's Avatar
    Join Date
    Oct 2008
    Posts
    985
    Yes its a one piece. Snapped it at the base. Not a clean break either.
    Sean K. likes this.
    'Courage is not the absences of fear, its the taking of action in the presences of fear."

  8. #7
    Expert Dredd's Avatar
    Join Date
    Oct 2008
    Posts
    985
    First I was shooting for function. Then I was shooting for accuracy (I use this term very loosely). I was 55-65 yards away from the targets. Then I did some rapid fire. After the Op-rod broke I wanted to see if would happen again. I will turn the gas to "S" and see if that reduces the pressure.
    'Courage is not the absences of fear, its the taking of action in the presences of fear."

Sponsors

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Sig xi 7.62 issues
    By DenisChamberlin in forum General Discussion
    Replies: 41
    Last Post: 12-18-2014, 10:21 PM
  2. New AR issues
    By saberune in forum General Discussion
    Replies: 12
    Last Post: 02-09-2013, 11:08 AM
  3. Accuracy issues with my XCR in 5.56
    By waveslayer in forum Problems
    Replies: 3
    Last Post: 02-08-2013, 05:42 PM
  4. Who has an -M? Any issues?
    By TomAiello in forum General Discussion
    Replies: 3
    Last Post: 11-25-2012, 02:57 PM
  5. Rock River PDS Piston (RRA Piston AR that isnt typical of others)
    By soapboxpreacher in forum General Discussion
    Replies: 9
    Last Post: 04-04-2011, 10:59 AM