XCR Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
635 Posts
Discussion Starter · #1 ·
Today I went to shoot my XCR. This is the first time since I upgraded to the new gas block. I took with seven 30rd mags and one 20 rd mag, plus a half a dry box of ammo.

Ammo used Wolf 62gr (black Box) in the 30rd mags. PMC 55gr SP in the 20rd mag. And IMI (M855) 62gr Green tip, & IMI 55gr ammo.

After target set up. I put the gas setting on #3. I put in the 20rd mag. All rounds fired just as they should. Spent cases landed about 10ft & about 2 o' clock, mag is now empty. So I reload with one of my 30rd mags (WOLF). The first round fails to eject. The bolt is stuck and I have to use my flathead screwdriver (that I keep for that purpose). I try again a few more times. Same thing, but I can use the charging handle it just takes a couple a toughs.

So now I change gas settings. This is when I notice the gas block has become loose. So I put is back in place an re tighten. I tried all five settings S 1-4 that same thing happens. So I decided to try my brass cased stuff. (It has always worked before). Nope, not this time. Same thing. Again settings S 1-4. The same thing the spent casing will not eject. Basically I have a bolt action XCR. It goes bang just fine.

Note: I did have to use a torch to get the old gas block off. (May be the source of the problem :duh:, hope not) It is like there is no gas flowing back to the piston. But when I looked @ it I see carbon on it.

Here are some photos. Any ideas ??? I am thinking about sending the barrel and piston/op-rod back to Rob-Arm to have them look @ it.









Edit: Made pictures smaller. 05/12/08
 

·
Registered
Joined
·
5,177 Posts
oh, no, jason. You might have a bad gas block. :( Seems like it functioned long enough to make it past the in-shop testing. I am still waiting on gas blocks - I'll have to get back to you on when I can get a replacement going. For now, you will need to switch back to the old one until I can get another for you. So sorry. :(
 

·
Registered
Joined
·
635 Posts
Discussion Starter · #3 ·
I took an acetylene torch to it. Trying to get it off. :( :( :( :(
 

·
Registered
Joined
·
2,200 Posts
Jb, I may be wrong, but a new gas system means A NEW BREAKIN PERIOD. Thats 300 rds on setting four. NO WOLF til that is done! Sorry to hear you are having problems, Terra can (will) help. :duh: ;D :2cents:
 

·
Registered
Joined
·
1,475 Posts
wow, those are some big pictures!

gunner poses an interesting question. If you switch to a new gas system or new bolt for example, do you need to do 300 at gas 4 again?
 

·
Registered
Joined
·
635 Posts
Discussion Starter · #8 ·
OK, Terra. Got your message. :)
 
1 - 8 of 8 Posts
Top