XCR Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
772 Posts
Discussion Starter #1
After about an 18 month wait, I was able to secure a 5.45x39 kit as well. Installed kit on my -L and hit the range today. Due to limited time, I was only able to pop 2 boxes of SilverBear 60grn FMJ. My rifle is well worn and my bolt carrier has 16k cycles on it. With the brand new kit and op-rod, (had to replace it due a crack) I shot 5 rounds on gas setting 3. The brass was flying about 40 feet from the rifle so I adjusted the gas to setting 2. On that setting the brass was flying about 20 feet from the rifle.

All 60 rounds cycled flawlessly using 1 c-products 30 round mag and 1 Lancer 20 round mag (5.56 type) Accuracy at 50 yards was slightly less the 2 inch groups.

Very happy so far with the new kit, can't wait to give a real work out.
 

·
Registered
Joined
·
3,593 Posts
Sounds like fun!
 

·
Registered
Joined
·
772 Posts
Discussion Starter #5
As soon as I get home from the range; rinse the broken down rifle with lots of hot water, blow dry with air compressor, then spray with CLP. I have not had any issues when I use this cleaning method after firing corrosive ammo.
 
  • Like
Reactions: crusoe

·
Registered
Joined
·
806 Posts
As soon as I get home from the range; rinse the broken down rifle with lots of hot water, blow dry with air compressor, then spray with CLP. I have not had any issues when I use this cleaning method after firing corrosive ammo.
Only thing I do different is spray Simple Green down the barrel and wait a few minutes - then the hot water and what cjt50 said.
 
1 - 6 of 6 Posts
Top