As the title states. Interested in either 6.8 or 5.56. Prefer newer version. Let me know what you have. Thanks!

Joe