XCR Forum banner
1 - 4 of 4 Posts

· Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
New XCR owner and really like it. However, after 400+ rounds, I'm getting light strikes...with all brands (Federal, PMC, Privi Part. ..all 55 gr). In today's outing, I had 6 of 80 rounds not firing (at least 1 of each brand). The attached photo shows the more pronounced dimple in the round that fired and the smaller one for the light strike. With almost 500 rounds, I'm expecting better by now. Advice?

Also (and forgive the ignorance of 5.56/.223 ballistic traits). My rounds keep rising depending on the distance to target. My shooting is confined to a 150' indoor range, which may not be a fair distance to draw conclusions, but the POI rises from 50' to 100' and again to 150' (in each case the POA is the middle if the black dot...I had zeroed at 100'). As above, this happens with Fed, PMC and PP, but the spread varies. Is it normal for the POI to keep rising like this?

Thanks in advance for your responses.
 

Attachments

· Registered
Joined
·
16 Posts
Discussion Starter · #4 ·
variablebinary - good tutorial, thank you. I assume that the practical answer to my question is that "yes, it climbs in the early feet from the muzzle (including within the first 150')." I'll note with respect that my outstanding Arsenal 7.62x39 does not demonstrate anywhere near the same climb differential (anticpiating a "mass-of-bullet" reply). I suppose I was expecting a simpler "it's normal, stupid, don't worry about it" response.

Tarra - VERY responsive, as per your normal monitoring of this Forum. Yes, it's a 5.56N and no trigger work has been done whatsoever...straight from the factory in late June. This is one awesome rifle and I plan to post a photo soon of my tweaking; but I need to resolve this reliability question (spoiled with an AK that's been zero-defect for over 4K rounds).

This is a great forum.
 

· Registered
Joined
·
16 Posts
Discussion Starter · #8 ·
Cleaned & lubricated thoroughly after every trip to the range, yes. Have inspected bolts but not detected a need to use Locktite (for the example, the infamous ejector seems as tight as day one). Barrell bolt did loosen slightly, but detected and corrected previously.
 

· Registered
Joined
·
16 Posts
Discussion Starter · #12 ·
LIGHT-STRIKE PROBLEM SOLVED! Thanks to Terra for sending the heavy hammer, which was quite easy to install. Fired 110 rounds this morning and function was 100% perfect, including re-firing 10 "retreads" from previous light-strikes.

Also, the tutorials on POI vs. POA were superb, thanks to all. The graphics were copied and are kept with the rifle for future reference.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top